This project is read-only.

What do folks think of the toolkit?

Coordinator
Mar 2, 2007 at 9:59 PM
Edited Mar 6, 2007 at 10:26 PM
We would love to hear your thoughts and questions. In particular, if you find any bugs or have have any problems running the toolkit, please do let us know and we'll work to answer your questions as soon as we can.

- the MSRIndia Team
Mar 10, 2007 at 5:50 AM
Great work guys!!

I just used this with yahoo api and now sign up & chat via SMS. Its fun, any plans to add support for other mobile phones??
Mar 10, 2007 at 6:07 AM
Edited Mar 10, 2007 at 6:24 AM
Nice, i downloaded it yesterday and tested my application with your emulator. Thinking about buying a windows mobile, any suggestion?

Thanks god, you used SQL mobile and not Express:)

John
Mar 10, 2007 at 6:21 AM
Very useful . Can I use it for commercial purpose?

Bill A
Mar 10, 2007 at 6:28 AM
Something is worng with my code, can you guys help me with that?

My client gets disconnected after every new sms rece. it was working fine sometime back :-(

Thanks a ton!

John
Mar 10, 2007 at 1:00 PM
I'm not quite sure what's going on with mine..

Most of the time it says "Phone Client Disconnected"

I modified the "Hello world" sample and put in a button to send a message on click.

It shows up in the outbox but the status never changes from 0.

I'm guessing it just stays connected long enough to process the incoming and outgoing. I'm not sure, since there is no documentation on this toolkit I have no idea if it's working. It just says "Phone Client Disconnected" then every now and then (I can't catch it) it changes to something else).
Mar 10, 2007 at 5:32 PM
A bit more informaiton.

This was a new service, I can send and receive txt msg's to the phone, it's running windows mobile 5.0.

The client comes on when I have the "SMS Server Agent" running, it pops open the client on the phone. Everything seems to be ok, but people send me messages and the agent never picks it up, or I send a message via code and the agent shows the message in the outbox but it never gets deleted.

I think alot of this has to do with the fact that the agent says "Phone client disconnected" though I don't know of any way to get it connected. There are no tools or help.

Any idea's?

Joe
Mar 10, 2007 at 6:51 PM
Looks good.

jfuentes i never had this problem, but i do work in mobiles a lot so my mobile is already in a programmer mode. It would be good if you guys can Sign your toolkit with a valid cert, so that a general phone can use it.

Vinay

PS: Is vibhore -> vibhore goyal from india??
Mar 10, 2007 at 7:36 PM
? Sign the toolkit?? Is the source aviable that we can sign? Cause all I got was an installer that installed everything.

How do you put a phone in programmer mode?

Thanks
Coordinator
Mar 11, 2007 at 3:09 AM
Joe- For unlocking the mobile phone please check the Hardware Requirement section of project homepage!
agcana - We may include support for GSM datacard and other Phones but its going to take some time
John - Any windows mobile 5.0 based mobile with work fine, just make sure its unlocked.
Mar 11, 2007 at 6:13 AM
Ok, well I went though the hardware requirements, I did what it said (changed the registry), then I get errors trying to run "SMS Server Agent" on the PC and it fails, this only happens the first time after I restart the PC. Every time after the errors pop up, and I try starting the "SMS Server Agent" again it does nothing, it says it's not connected to the client.

SO then I use the tool mentioned at the bottom of the hardware requirement.. I get everything changed just as it discribes but stil nothing. After using the tool at least the agent on the PC doesn't bug out anymore, but it still doesn't connect.

I'm using a windows mobile 5.0 Motorola Moto Q phone and the PC is a Windows XP Pro with SP2.

I would really like to get this working cause I'm very excited about the possiblities.

I also figured that since the security had changed that maybe I needed to uninstall and reinstall, but that didn't help either.

So still not communicating. Funny thing is, the "SMS Server Agent" does get the agent on the mobile to start up, it just never connects past startup.

Any help would be great.

Jose
Mar 11, 2007 at 3:39 PM
Oh BTW, I'm sure we will get this all figured out and working, though I have a question, the requirements for running this say Windows vista or XP, what about windows server 2003? I plan to put it there, hence people are not going to make a real service and put it on a XP/Vista machine.

Thanks for all the help BTW.

Jose
Coordinator
Mar 12, 2007 at 8:53 AM
Jose - I didnt try my code on windows 2003, but i cant think of any reason why it shouldnt. Will try to check it on 2k3 and update the requirement section.
Mar 14, 2007 at 12:10 PM
I am stuck with client continuously polling for server agent.

I have connected the Windows Mobile emulator made the necessary secutiy policy registry changes but still it is not connecting with client agent.

I have also made provision for securiy off.

Pramod
Coordinator
Mar 14, 2007 at 11:08 PM
Pramod - Some mobile phones has applications which are using the same communication port, i will publish an update for the toolkit tonight, which most like solve this problem. I am not sure if you are having the same problem, so if you can explain whats exactly going on your side will help. May be you can send me a screen shot on

vibhoreg at microsoft.com

Vibhore Goyal
Apr 29, 2007 at 5:38 PM
When I run the Exell sample or the SmsDesktopAgent.exe, I receive the following exception :

System.DllNotFoundException: Impossibile to load the DLL 'sqlceme30.dll': Impossible to find the module. (Eccezione da HRESULT: 0x8007007E).
in System.Data.SqlServerCe.NativeMethods.CreateErrorInstance(IntPtr& pError)

I have already installed SQL Compact edition 2005
Coordinator
Apr 30, 2007 at 5:55 PM
uniprof - do a search for sqlceme30.dll on you machine and copy all the dll files(around 7 dll files) from that folder to installation folder of smstoolkit ( c:\program file\Msr india\sms smsserver\). This normally happens when the registry entries are not correctly set by SQL compact edition. You can also try reinstalling the SQL Compact edition 2005.

mail me on vibhoregoyal at gmail dot com , in case you have trouble solving this problem!!

Vibhore
Dec 12, 2007 at 5:51 AM
I have cingular 8125 phone and I have followed all the instructions however when I start the sms server agent the client boots up on my phone as well, however the server says connecting with phone client and never actually connects. Please advise
Feb 20, 2008 at 4:59 PM
destynni,
I have the same issue. Were you able to get it working? Please help.

Thanks in advance,
George


destynni wrote:
I have cingular 8125 phone and I have followed all the instructions however when I start the sms server agent the client boots up on my phone as well, however the server says connecting with phone client and never actually connects. Please advise